Installing Swoole via Open Swoole Debian/Ubuntu PPA

2 min read

By Luke Embrey @ Swoole Labs

Open Swoole can now be installed via the Open Swoole Debian/Ubuntu PPA, the openswoole/ppa PPA can be added to your package sources by running the following commands on Ubuntu/Debian:

#!/bin/bash

# Install the Deb.Sury PHP Ubuntu PPA source
$ sudo apt install software-properties-common
$ sudo add-apt-repository ppa:ondrej/php
$ sudo add-apt-repository ppa:openswoole/ppa
$ sudo apt-get update

Then after you have PHP installed, you can install a compatible version of Swoole which is prebuilt:

#!/bin/bash

# Install Swoole for PHP 8.0
$ sudo apt install php8.0-openswoole

# Check that Swoole is loaded
$ php -m | grep openswoole

The Open Swoole Debian/Ubuntu PPA will only support the latest supported versions of PHP, so make sure you have a compatible PHP version installed.

This is a great way to quickly get started with Open Swoole, everything gets configured for you, so it is easy for beginners to start with Swoole. There is specific Open Swoole PPA documentation for this as well.

For more information and documentation on installing Open Swoole checkout the getting started guide and the installation guides.

Additionally, Open Swoole can be installed multiple ways, check the full documentation to see how to install via:

  • PHP PECL binary release
  • Building from source via GitHub